注意!! この投稿は1年と1ヶ月くらい前に公開したものです。
そのため正常に動作しないかもしれないので、ご注意ください。

WP-CLI のバージョン0.22以下はこれからリリースされるWordPress 4.5と互換性がないとのことなのでご注意を!

WP-CLIのバージョン0.23.0がリリースされました。これ以前のWP-CLIはこれからリリースされるWordPress 4.5とは互換性がないとのことなので、ご注意を!

Version 0.23.0 released | WP-CLIより、

This release includes WordPress 4.5 compatibility. Older WP-CLI versions are incompatible with WordPress 4.5. If you’re planning to use WordPress 4.5 in the future, you’ll need to upgrade before you do.

このリリースにはWordPress 4.5との互換性が含まれています。古い WP-CLIのバージョンはWordPress 4.5との互換性がありません。WordPress 4.5を使う予定であれば、WordPress 4.5がリリースされる前にWP-CLIをアップグレードしてください。